» » » Multi XFields v1.3 и Добавление в новость v4.0.3 [10.2]

Multi XFields v1.3 и Добавление в новость v4.0.3 [10.2]

Название: Multi XFields v1.3 и Добавление в новость v4.0.3
Автор: Mehmet Hanoğlu & n0wheremany
CMS: DLE 10.2 UTF-8

Описание:
Последняя версия модуля Multi XFields и обновлённая версия Добавление в новость v4.0.3 под DLE 10.3.



  • Имя файла: multi-xfields-v1.3_multi_fields_4.0.3.rar
  • Размер: 30,42 Kb
  • cкачиваний: 553
  • Md5: d4e7c73fdb2f3bd8baf2d933e33ffa3d
  • Sha1: b9ea7670315a685174daaa91c316bfcccc1968f9
  • Скачать

  • Имя файла: multi-xfields-v1.3_tr.rar
  • Размер: 18,94 Kb
  • cкачиваний: 261
  • Md5: 0092548ab58336c1cfab1230ba21f47d
  • Sha1: f6b3ff248ede151723126d4e1758730af08c0bae
  • Скачать



Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Комментарии

4
под DLE 10.3.

Исправьте.
4

MaHarder

Посетители 21 августа 2014 20:38
Цитата: Alexh2o345
под DLE 10.3.

Исправьте.

наверно моя опечатка. не могу исправить, нет прав.
4
По нажатию на "Загрузить по URL" ничего не происходит.
4

MaHarder

Посетители 22 августа 2014 15:54
Цитата: danil031997
По нажатию на "Загрузить по URL" ничего не происходит.

всё работает. проверьте права на папки. вот видео. на локалке и на сервере. на сервере пока ещё не выставлены права.
http://youtu.be/qR_LuVHfh0M
4
Цитата: MaHarder
Цитата: danil031997
По нажатию на "Загрузить по URL" ничего не происходит.

всё работает. проверьте права на папки. вот видео. на локалке и на сервере. на сервере пока ещё не выставлены права.
http://youtu.be/qR_LuVHfh0M

Странно, но всплывающее окно со вставкой ссылки у меня не всплывает. Как-будто событие у кнопки отсутствует. Через пк файлы льются отлично.

При нажатии на ту кнопку, ссылается на файл jquery.xf.upload.js:

Uncaught ReferenceError: dle_prompt is not defined jquery.xf.upload.js:17
(anonymous function) jquery.xf.upload.js:17
x.event.dispatch application.js:5
y.handle
4

MaHarder

Посетители 22 августа 2014 16:41
наверно дело в конфликте с джекьюри

ты заменил файл xfields.php в папке inc?
4
Цитата: MaHarder
ты заменил файл xfields.php в папке inc?

да, все файлики аккуратно заменил. подожду DLE 10.3, и на чистую накачу.
4
точно под 10.2 работает "Добавление файлов в новость v4.0.3"?
4

souz21

Посетители 27 сентября 2014 11:33
Ничего не исправлено. По прежнему с сайта нельзя добавить изображения. тупо строка типа image:size=100,nothumb,notag,urlfile. Кнопки нет.
4

Orochimaru

Посетители 2 января 2015 13:48
Цитата: souz21
Ничего не исправлено. По прежнему с сайта нельзя добавить изображения. тупо строка типа image:size=100,nothumb,notag,urlfile. Кнопки нет.

если не ошибаюсь, нужно файл fullstory.tpl подправлять под этот модуль...
4

Shnapik

Посетители 2 января 2015 18:42
Цитата: Orochimaru
Цитата: souz21
Ничего не исправлено. По прежнему с сайта нельзя добавить изображения. тупо строка типа image:size=100,nothumb,notag,urlfile. Кнопки нет.

если не ошибаюсь, нужно файл fullstory.tpl подправлять под этот модуль...

fullstory.tpl - это всего то файл содержащий шаблон. Там нечего подправлять.
4

vadims

Посетители 28 января 2015 00:37
Пару дней назад ставил этот модуль и подобная ерунда в 10.3 - в админке все ок, а на сайте строка -

В 10.3 чтобы работала загрузка с сайта+админки нужно добавить код в 2 местах -

if ($xfieldmode == "site") {

$is_xfields_upload = false;
$xfields_upload_action = 'view';
$xfields_upload_field = $value;
$xfields_upload_value = $fieldvalue;
include ENGINE_DIR . '/inc/xfields.upload.php';
if (!$is_xfields_upload)


$output .= <<<HTML
<tr id="$holderid" {$uid}>
<td class="addnews">$value[1]:</td>
<td class="xfields" colspan="2"><input type="text" name="xfield[$fieldname]" id="xf_$fieldname" value="$fieldvalue" {$params}/>  [if-optional]({$lang['xf_not_notig']})[/if-o
ptional][not-optional]({$lang['xf_notig']})[
; ; ; ;/not-optional]</td> </tr> HTML; } else { $is_xfields_upload = false; $xfields_upload_action = 'view'; $xfields_upload_field = $value; $xfields_upload_value = $fieldvalue; include ENGINE_DIR . '/inc/xfields.upload.php'; if (!$is_xfields_upload)


Чтобы на сайте удалялись файлы нужно в engine/classes/js/jquery.xf.upload.js
удалить -
if(jQuery.browser.msie)this.make_parent_opaque();


Чтобы загруженные файлы были не с прозрачным фоном -
engine/classes/js/jquery.xf.upload.css
после
.n0upload .n0uploadList .error{


добавить
background: #fff;
text-shadow: 0 1px 0 #fff;
font-size:13px; 
color: #596368;


тут же
background: #fff url("/engine/skins/images/fbutton.png") repeat-x 0 100%;

заменить на
background: #fff;


или картинку загрузить в /engine/skins/images

Поправьте архив в новости, чтобы работало на 10.3
4
А под кодировку 1251 есть ?
4

MaHarder

Посетители 22 марта 2015 17:59
Цитата: AleksShadowman
А под кодировку 1251 есть ?

пробуй перекодировать
Цитата: vadims

Поправьте архив в новости, чтобы работало на 10.3

спасибо, поправлю. Однако, поскольку не использовал добавление новости с сайта, подобного не замечал )
4

SoulRiver

Посетители 4 июня 2015 11:36
Кто подскажет в чем может быть проблема!?
на сайте доп. поле "Мультивыбор" отображается в самом начале (перед заголовком статьи) все остальные доп. поля отображаются верно!
И vadims напиши пожалуйста где именно прописать данный код. заранее спасибо!
4

vadims

Посетители 18 июня 2015 11:27
Цитата: SoulRiver
Кто подскажет в чем может быть проблема!?
на сайте доп. поле "Мультивыбор" отображается в самом начале (перед заголовком статьи) все остальные доп. поля отображаются верно!
И vadims напиши пожалуйста где именно прописать данный код. заранее спасибо!


Ставьте хак - http://nowheredev.ru/developments/php/65-dopolnitelnye-polya-v-dobavlenii-novost
ey.html
4

FC1488SM

Посетители 22 июня 2015 15:22
http://clip2net.com/s/3jF6hj3

из-за чего эта ошибка возникает?
4

SoulRiver

Посетители 12 июля 2015 09:36
Цитата: vadims
if ($xfieldmode == "site") {

можно поподробнее...куда вставлять...заранее благодарен!
CMS DLE 10.5
4

spilden01

Посетители 21 июля 2015 20:50
Цитата: SoulRiver
Цитата: vadims
if ($xfieldmode == "site") {

можно поподробнее...куда вставлять...заранее благодарен!
CMS DLE 10.5

Тоже интересует этот вопрос
4

SoulRiver

Посетители 24 июля 2015 03:57
Цитата: spilden01
Цитата: SoulRiver
Цитата: vadims
if ($xfieldmode == "site") {

можно поподробнее...куда вставлять...заранее благодарен!
CMS DLE 10.5

Тоже интересует этот вопрос

Если необходимо то могу отправить файл исправленный. Заменишь или же по нему сверишься...
Пиши в ЛС. И да хак тоже поставь!
4

Ups

Посетители 7 ноября 2015 16:35
Может кто помочь с этим файлом ? Или может есть у кого то уже исправленный этот модуль ? Не работает на сайте.. только в админке работает..
http://f1.s.qip.ru/iJXXcsek.png

На сайте тупо такое поле..
4

dep-lit

Посетители 11 февраля 2016 18:40
файл engine/inc/xfields.php
для ДЛЕ 10.6 такая строчка
if (($value[8] == 1 OR $value[6] == 1 OR $value[3] == "select") AND $postedxfields[$value[0]] != "" ) {

вставить выше
if (stripos($value[4],'audio')===0 or stripos($value[4],'video')===0 or stripos($value[4],'image')===0 or stripos($value[4],'file')===0) $value[3] = 'textarea';

файл engine\classes\js\jquery.xf.upload.js
Удалите этот код:
if(jQuery.browser.msie)this.make_parent_opaque();

найти:
$(".n0upload .n0uploadList span.close").live("click"

заменить:
$(".n0upload .n0uploadList").on("click", "span.close"

Информация

Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.